How to Resolve Intel® Optane™ Memory Pinning Error: Unable to load DLL ‘iaStorAfsServiceApi.dll

Documentation

Error Messages

000055631

11/08/2019

In this article, you'll learn more about why the following error appears and how to resolve the issue.

Issue details
After a Windows® 10 update, the following error message appears randomly during use of the system.

 

Root cause
During a major OS update, all devices are reinstalled with the best matching drivers. With 17.5.0.1017 RST driver, the way the Intel® Optane™ memory pinning components are installed was modified. If at some point the driver was upgraded from a version earlier than 17.5.0.1017 to a newer one, OS update may try to reapply the removed installation files from the earlier versions.  Due to a compatibility issue, an error message may occur.

How to fix
This issue can be resolved by doing the following:

First, refresh the current driver package installed by repairing the Intel® Optane™ memory pinning extensions:

  1. Open Programs and Features (Press Windows key  + r).
  2. Type ‘appwiz.cpl’ and click OK.
  3. Locate and highlight Intel Optane Pinning Explorer Extensions.
  4. ClickRepair.

 

 

Second, remove the old pinning package so that the error does not reappear after the next OS update:

  1. Open Device Manager (Press Windows key + x).

  2. Expand the Software components field.
  3. Right-click the Intel® Pinning Shell Extensions field and select Uninstall Device.

  4. Check the box that states Delete the driver software for this device. and click Uninstall.

If you continue to see issues, contact Intel Customer Support for assistance.

 

Related topics
What is Pinning with Intel® Optane™ Memory?